Si vous rencontrez des problèmes lors de l'installation d'un certificat SSL sur votre domaine, CyberPanel génère un certificat auto-signé à la place. Ce certificat, cependant, n'est pas acceptable pour la majorité des navigateurs et provoque un écran rouge d'avertissement. Vous trouverez ci-dessous les étapes à suivre pour résoudre ce problème.

Pour toutes les étapes, vous devez accéder au root de votre VPS via SSH. Après chaque étape, vous devrez revérifier le statut du certificat SSL, pour voir si votre dernière action l'a réparé.

  1. Mettez à niveau CyberPanel vers la dernière version. Cela peut être fait en exécutant cette commande SSH :

    sh <(curl https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh || wget -O - https://raw.githubusercontent.com/usmannasir/cyberpanel/stable/preUpgrade.sh)
  2. Mettez à niveau le client SSL ACME vers la dernière version. Pour cela, exécutez la commande suivante :

    wget -O - https://get.acme.sh | sh
  3. Vérifiez les journaux d'erreurs supplémentaires :

    cat /home/cyberpanel/error-logs.txt

    Vous pouvez trouver des erreurs spécifiques, en les corrigeant vous serez en mesure de résoudre l'erreur du certificat SSL.

  4. Exécuter l'installation de SSL avec le flag de débogage :

    /root/.acme.sh/acme.sh --issue -d yourdomain.com -d www.yourdomain.com --cert-file /etc/letsencrypt/live/www.rmronsol.com/cert.pem --key-file /etc/letsencrypt/live/yourdomain.com/privkey.pem --fullchain-file /etc/letsencrypt/live/yourdomain.com/fullchain.pem -w /home/yourdomain.com/public_html --server letsencrypt --force --debug

REMARQUE :

Avez-vous trouvé votre réponse?